System Requirements

16 Nov 2015 - 00:03 | Version 1 |

Low client and server base requirements are core features that keep Foswiki widely deployable, particularly across a range of browser platforms and versions. Many extensions exist which enhance and expand Foswiki's capabilities; they may have additional requirements.

Server Requirements

Foswiki is written in Perl 5, which is supported on Microsoft Windows as well as Unix and Unix-like systems (including Linux and OSX). On Unix-like systems, it uses a number of shell commands. It should be able to run out-of-the-box on any server platform that meets the following requirements.

Resource Required Server Environment
Perl 5.8.8 or higher. A minimum of perl 5.12 is recommended.
External programs GNU diff 2.7 or higher, fgrep, and egrep (not required on Windows)
Web server Apache, Nginx and Lighttpd are all well supported; Apache sample configs are provided. For information on other servers, see Foswiki:Support.InstallingOnSpecificPlatforms.

Foswiki is designed to automatically detect the platform and generate a basic configuration the first time the configure script is run, but start from your expected default "view" URL, so that Foswiki can figure out your URL scheme.

Prior versions of Foswiki shipped with the important CPAN modules. Foswiki 2.0 does not, and you must ensure that the perl dependencies listed below are installed before attempting to use Foswiki. For a detailed report, See PerlDependencyReport (admin access only!) or the shell script tools/dependencies.

If you are unable to install CPAN modules, see Foswiki:Extensions.CpanContrib. Install this extension into your Foswiki installation directory if you cannot install Perl modules otherwise.

You can check the dependencies before Foswiki is fully operational with the following command. It will list all potentially missing dependencies. Not all listed dependences are required on all installations, Refer to the usage message that accompanies each missing dependency in the report.

cd /path/to/foswiki
perl tools/dependencies

Specific distribution details

Find the closest match to your installed system. and click on the "Show ..." link to reveal the details.

Ubuntu and other Debian derived distributions

Minimum requirements

Install apache and rcs: apt-get install apache2 rcs

Perl Module Package to install Notes
Algorithm::Diff libalgorithm-diff-perl  
Archive::Tar libarchive-tar-perl  
Authen::SASL libauthen-sasl-perl  
CGI libcgi-pm-perl  
CGI::Session libcgi-session-perl  
Crypt::PasswdMD5 libcrypt-passwdmd5-perl  
Digest::SHA libdigest-sha-perl *First shipped in perl 5.9.3
Encode libencode-perl  
Error liberror-perl  
File::Copy::Recursive libfile-copy-recursive-perl  
HTML::Parser libhtml-parser-perl  
HTML::Tree libhtml-tree-perl  
IO::Socket::IP libio-socket-ip-perl First shipped perl 5.19.8
IO::Socket::SSL libio-socket-ssl-perl  
JSON libjson-perl  
Locale::Maketext liblocale-maketext-perl  
Locale::Maketext::Lexicon liblocale-maketext-lexicon-perl Optional, needed for internationalization
Locale::Msgfmt liblocale-msgfmt-perl Optional, needed for internationalization
LWP libwww-perl  
URI liburi-perl  
version libversion-perl Must be version 0.77 or newer, included with perl 5.10.1 and newer.

Note: to install all the above: apt-get install libalgorithm-diff-perl libarchive-tar-perl libauthen-sasl-perl libcgi-pm-perl libcgi-session-perl libcrypt-passwdmd5-perl libdigest-sha-perl libencode-perl liberror-perl libfile-copy-recursive-perl libhtml-parser-perl libhtml-tree-perl libio-socket-ip-perl libio-socket-ssl-perl libjson-perl liblocale-maketext-perl liblocale-maketext-lexicon-perl liblocale-msgfmt-perl libwww-perl liburi-perl libversion-perl

Optional dependencies

Install as needed.

Perl Module Package to install Notes
Apache2::Request libapache2-request-perl Required if using Apache 2 and mod_perl
DBI libdbi-perl Used for the Foswiki Page cache
DBD::mysql libdbd-mysql-perl Used for MySQL based Page Cache
DBD::Pg libdbd-pg-perl Used for PostgreSQL based Page Cache
DBD::SQLite libdbd-sqlite3-perl Used for SQLite based Page Cache
FCGI libfcgi-perl Optional, needed for fastcgi / fcgi apache modules

After expanding the Foswiki archive, change the ownership of the files:
  • Debian, Ubuntu, Kubunto: chown -R www-data:www-data /path/to/foswiki

Apache user should issue the following commands:
a2enmod rewrite
Enables mod_rewrite
a2enmod cgi OR a2enmod cgid
Enables CGI. May need cgid if using a threaded mpm.
a2enmod access_compat
Apache 2.4: Enables compatibility with foswiki example apache configurations.

RedHat, SuSE, CentOS and other RPM based distributions

Minimum requirements

Install apache2, rcs, and perl-CPAN

Perl Module Package to install Notes
Algorithm::Diff perl-Algorithm-Diff  
Archive::Tar perl-Archive-Tar *First shipped in perl 5.9.3
Authen::SASL perl-Authen-SASL  
CGI perl-CGI  
CGI::Session perl-CGI-Session  
Crypt::PasswdMD5 perl-Crypt-PasswdMD5  
Digest::SHA perl-Digest-SHA *First shipped in perl 5.9.3
Encode perl-Encode  
Error perl-Error  
File::Copy::Recursive perl-File-Copy-Recursive  
HTML::Parser perl-HTML-Parser  
HTML::Tree perl-HTML-Tree  
IO::Socket::IP perl-IO-Socket-IP First shipped perl 5.19.8
IO::Socket::SSL perl-IO-Socket-SSL  
JSON perl-JSON  
Locale::Language perl-Locale-Codes  
Locale::Maketext perl-Locale-Maketext  
Locale::Maketext::Lexicon perl-Locale-Maketext-Lexicon Optional, needed for internationalization
Locale::Msgfmt perl-Locale-Msgfmt Optional, needed for internationalization
LWP perl-libwww-perl  
URI perl-URI  
version perl-Perl-Version Must be version 0.77 or newer, included with perl 5.10.1 and newer.

Optional dependencies

Install as needed.

Perl Module Package to install Notes
Apache2::Request perl-libapreq2 Required if using Apache 2 and mod_perl
DBI   Used for the Foswiki Page cache
DBD::mysql   Used for MySQL based Page Cache
DBD::Pg   Used for PostgreSQL based Page Cache
DBD::SQLite   Used for SQLite based Page Cache

After expanding the Foswiki archive, change the ownership of the files:
  • RedHat, Fedora, CentOS Mandriva: chown -R apache:apache /path/to/foswiki=
  • Suse: chown -R wwwrun:www /path/to/foswiki

Gentoo (ebuild) based distributions

Minimum requirements

Install www-servers/apache, dev-vcs/rcs, and dev-lang/perl

Perl Module Package to install Notes
Algorithm::Diff dev-perl/Algorithm-Diff  
Apache2::Request www-apache/libapreq2 Required if using Apache 2 and mod_perl
Archive::Tar perl-Archive-Tar *First shipped in perl 5.9.3
Authen::SASL dev-perl/Authen-SASL Optional, needed for authenticated SMTP
CGI perl-core/CGI  
CGI::Session dev-perl/CGI-Session  
Crypt::PasswdMD5 dev-perl/Crypt-PasswdMD5  
Digest::SHA perl-core/Digest-SHA Included with perl
Error dev-perl/Error  
Encode perl-core/Encode  
File::Copy::Recursive dev-perl/File-Copy-Recursive  
HTML::Parser dev-perl/HTML-Parser  
HTML::Tree dev-perl/HTML-Tree  
IO::Socket::IP dev-perl/IO-Socket-IP  
IO::Socket::SSL dev-perl/IO-Socket-SSL Optional, support encrypted email connection: STARTTLS or SSL
JSON dev-perl/JSON  
Locale::Maketext dev-perl/locale-maketext  
Locale::Maketext::Lexicon dev-perl/locale-maketext-lexicon Optional, needed for internationalization
Locale::Msgfmt dev-perl/Locale-Msgfmt Optional, needed for internationalization
LWP dev-perl/libwww-perl  
version perl-core/version Must be version 0.77 or newer, included with perl 5.10.1 and newer.
URI dev-perl/URI  
* Packages in perl-core/ generally are installed with perl. May be directly installed if updated versions are available.

Optional dependencies

Install as needed.

Perl Module Package to install Notes
Apache2::Request libapache2-request-perl Required if using Apache 2 and mod_perl
DBI   Optional - Used for the Foswiki Page cache
DBD::mysql   Optional - Used for MySQL based Page Cache
DBD::Pg   Optional - Used for PostgreSQL based Page Cache
DBD::SQLite   Optional - Used for SQLite based Page Cache

After expanding the Foswiki archive, change the ownership of the files:
  • chown -R apache:apache /var/www/path-to-foswiki

Installation with CPAN

Perl dependencies can also be installed on most systems using cpanm, aka App::cpanminus. On most unix* systems, cpanminus can bootstrap itself using curl or wget. If run as root, the modules will be installed in the System perl. Otherwise they are installed into the users local environment.

Perl Module Notes
Algorithm::Diff  
Apache2::Request Required if using Apache 2 and mod_perl
Archive::Tar *First shipped in perl 5.9.3
Authen::SASL Optional, needed for authenticated SMTP
CGI  
CGI::Session  
Crypt::PasswdMD5  
Digest::SHA Included with perl
Error  
Encode  
File::Copy::Recursive  
HTML::Parser  
HTML::Tree  
IO::Socket::IP  
IO::Socket::SSL Optional, support encrypted email connection: STARTTLS or SSL
JSON  
Locale::Maketext  
Locale::Maketext::Lexicon Optional, needed for internationalization
Locale::Msgfmt Optional, needed for internationalization
LWP  
version Must be version 0.77 or newer, included with perl 5.10.1 and newer.
URI  

Optional dependencies

Install as needed.

Perl Module Package to install Notes
Apache2::Request Required if using Apache 2 and mod_perl
DBI   Optional - Used for the Foswiki Page cache
DBD::mysql   Optional - Used for MySQL based Page Cache
DBD::Pg   Optional - Used for PostgreSQL based Page Cache
DBD::SQLite   Optional - Used for SQLite based Page Cache

Installation using cpanminus

See Foswiki:Support.HowToInstallCpanModules for more information.
curl -L http://cpanmin.us | perl - App::cpanminus    (optional - install cpanminus if not available )
cpanm Algorithm::Diff Archive::Tar Authen::SASL CGI CGI::Session Crypt::PasswdMD5 DBI DBD::mysql DBD::Pg DBD::SQLite Digest::SHA Error Encode File::Copy::Recursive HTML::Parser HTML::Tree IO::Socket::IP IO::Socket::SSL JSON Locale::Maketext  Locale::Maketext::Lexicon Locale::Msgfmt LWP version URI

If you want to install the dependendencies into a specified location, add the "-l" option to cpanm, and add the lib path to bin/LocalLib.cfg. The dependencies will be installed under the specified location, in the lib/perl5 subdirectory. Example: User "foswiki" logs in and installs the libraries locally under the foswikideps directory:
cpanm -l foswikideps Algorithm::Diff Archive::Tar ...   (install libraries into =/home/foswiki/foswikideps=)

/path/to/foswiki/bin/LocalLib.txt is then edited, and the commented line is modified:
# @localPerlLibPath = ( '/path/to/dir', '/path/to/another/dir', );
@localPerlLibPath = ( '/home/foswiki/foswikideps/lib/perl5', );

Foswiki will now run using the libraries installed by cpanm.

Client Requirements

The standard installation has relatively low browser requirements:

  • XHTML 1.0 Transitional compliant
  • Cookies, if persistent sessions are required
  • Javascript, is required for configure, edit save and upload functionality. Foswiki is viewable without javascript.

CSS and Javascript are used in most skins. Some skins will require more recent releases of browsers. The default (Pattern) skin is tested on IE 6+, Safari, Chrome and Firefox.

You can easily select a balance of browser capability versus look and feel. Try the installed skins at SkinBrowser and more at Foswiki:Extensions.SkinPackage.


Related Topics: AdminDocumentationCategory

This site is powered by FoswikiCopyright © by the contributing authors. All material on this site is the property of the contributing authors.
Ideas, requests, problems regarding NCSS Leaders-Board? Send feedback